Ensure compatible Firefox Browser is installed

Ensure compatible Firefox Browser is installed

Before Running the created Selenium RC Test we’ve to verify whether a compatible Firefox Browser is installed on your machine.

1. Firefox browser version you are using in your computer machine should be compatible with the Selenium Standalone Server version you are using 


1. View the version of the Selenium Standalone Server  you are using as shown below:

2. Go to http://selenium.googlecode.com/git/java/CHANGELOG and start reading from the first line to find out the first occurrence of “Firefox Version Support” text as shown below:

3. I am writing this post on  March 8th 2013, after I read the above change log from the beginning  I found   “Firefox 18 Support” as the first occurrence of the “Firefox Version Support” text.  And from this log its very clear that Firefox 18 Support is available for the selenium versions starting from 2.29.0 and above as shown below:

4. As I’m using Selenium Standalone Server version 2.31.0  , which is higher than 2.29.0 version and Firefox 18 support is there for versions 2.29.0 and higher versions. Hence Firefox 18 browser is compatible with 2.31.0 version

5. But can I use Firefox 19 browser with Selenium 2.31.0 version as it is available currently. Will my test run ?  The answer is No. Though the latest Firefox version is available, your test wont run if the browser version is not compatible with the selenium version you are using.

2. How to install an older version of Firefox that is compatible with Selenium server version you are using

1. Suppose I’ve Firefox 19 installed on my machine currently but I need Firefox 18 version which supports the Selenium Server version I’m using.
2. I will first of all uninstall the Firefox 19 installed on my machine
3. In order to get the older releases of Firefox, I will open http://filehippo.com/download_firefox/ in my browser and click on ‘Firefox 18’ version as shown below:

4. In ‘Firefox 18’ page of  “Filehippo.com” website, click on the ‘Download this Version’ option as shown below:

5. Install the newly downloaded Firefox 18.exe  file
6. But on launching the Firefox Browser the Firefox version will get upgraded to the latest version. To avoid this go through the following steps immediately after launching the Firefox browser
7. Click on the ‘Tools’ Menu and select ‘Options’ option

8. Select the ‘Advanced’ tab in the displayed ‘Options’ dialog and select ‘Never check for Updates’ option as shown below and click on ‘OK’ button:

9. Click on Firefox Browser -> ‘Help’ Menu and click on ‘About Firefox’ option as shown below:

10. Ensure that ‘About Firefox’ dialog is displayed and confirm that you have “Firefox 18” version in the details as shown below:

Advertisements
%d bloggers like this: